Performance degradation - BESTpack - Pharmacy

Incident Report for BESTMED

Resolved

We apologise for the recent performance degradation on BESTpack - Pharmacy. The issue has been resolved and BESTpack - Pharmacy is now operating normally. Thank you for your patience.
Posted Mar 03, 2026 - 13:26 AEDT

Identified

We are currently experiencing some performance degradation on BESTpack - Pharmacy. This may cause slow loading times or other issues. We are working to resolve the issue as soon as possible. We apologise for the inconvenience.
Posted Mar 03, 2026 - 13:12 AEDT
This incident affected: BESTpack - Pharmacy.